From: Eric Dumazet <redacted>
Date: Tue, 27 Sep 2011 08:00:49 +0200
struct tcp_skb_cb contains a "flags" field containing either tcp flags
or IP dsfield depending on context (input or output path)
Introduce ip_dsfield to make the difference clear and ease maintenance.
If later we want to save space, we can union flags/ip_dsfield
Signed-off-by: Eric Dumazet <redacted>
Applied, thanks Eric.
If there is no objection, I plan to rename "flags" to "tcp_flags" in a
following patch.
No objections.