Thread (12 messages) flat view 12 messages, 8 authors, 2011-03-25

Re: [RFC] usbnet: use eth%d name for known ethernet devices

From: Arnd Bergmann <arnd@arndb.de>
Date: 2011-03-25 11:57:49
Also in: lkml

Possibly related (same subject, not in this thread)

On Thursday 24 March 2011, Alexey Orishko wrote:
On Thu, Mar 24, 2011 at 2:15 PM, Arnd Bergmann [off-list ref] wrote:
quoted
The approach taken here is to flag whether a device might be a
point-to-point link with the new FLAG_PTP setting in the usbnet
driver_info. A driver can set both FLAG_PTP and FLAG_ETHER if
it is not sure (e.g. cdc_ether), or just one of the two.
quoted
The usbnet framework only looks at the MAC address for device
naming if both flags are set, otherwise it trusts the flag.
Should this paragraph above be a clue for the flag name?
Sorry for late comment, but having flag called FLAG_POINTTOPOINT is really
confusing. ptp, p2p terms are heavily used and will mislead folks.

Would it be better to call it something like IGNORE_MAC_ADDRESS if this is the
feature you are targeting?
That would be a different way of looking at it.  FLAG_POINTTOPOINT
describes what the device is (a USB cable connecting two hosts), and
that flag can be used for various things, where the only thing
we currently do is the netif naming.

FLAG_IGNORE_MAC_ADDRESS as you suggest describes the implementation
of the device naming, not why that is done.

The intent here was to some something that makes sense next to
FLAG_ETHER, FLAG_WWAN and FLAG_WLAN. I think FLAG_POINTTOPOINT
describes this best, although I'd also be happy with FLAG_PTP,
FLAG_P2P, FLAG_CABLE or FLAG_USBCABLE.

	Arnd
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help