Thread (12 messages) flat view 12 messages, 8 authors, 2011-03-25

Re: [RFC] usbnet: use eth%d name for known ethernet devices

From: Alexey Orishko <hidden>
Date: 2011-03-24 17:20:49
Also in: lkml

Possibly related (same subject, not in this thread)

On Thu, Mar 24, 2011 at 2:15 PM, Arnd Bergmann [off-list ref] wrote:
The approach taken here is to flag whether a device might be a
point-to-point link with the new FLAG_PTP setting in the usbnet
driver_info. A driver can set both FLAG_PTP and FLAG_ETHER if
it is not sure (e.g. cdc_ether), or just one of the two.
The usbnet framework only looks at the MAC address for device
naming if both flags are set, otherwise it trusts the flag.
Should this paragraph above be a clue for the flag name?
Sorry for late comment, but having flag called FLAG_POINTTOPOINT is really
confusing. ptp, p2p terms are heavily used and will mislead folks.

Would it be better to call it something like IGNORE_MAC_ADDRESS if this is the
feature you are targeting?

/Alexey
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help