Re: [PATCH net-next-2.6] etherdevice.h: Add is_unicast_ether_addr function
flat view
From: Eric Dumazet <hidden>
Date: 2011-01-13 08:55:22
Le jeudi 13 janvier 2011 à 00:24 -0800, Joe Perches a écrit :
On Thu, 2011-01-13 at 09:14 +0100, Tobias Klauser wrote:quoted
quoted
From a check for !is_multicast_ether_addr it is not always obvious thatwe're checking for a unicast address. So add this helper function to make those code paths easier to read. include/linux/etherdevice.h | 11 +++++++++++[]quoted
/** + * is_unicast_ether_addr - Determine if the Ethernet address is unicast + * @addr: Pointer to a six-byte array containing the Ethernet address + * + * Return true if the address is a unicast address. + */ +static inline int is_unicast_ether_addr(const u8 *addr) +{ + return !is_multicast_ether_addr(addr); +}Can't you simply use is_valid_ether_addr? I can't think of much reason that a new function for !multicast without the !is_zero is needed.
performance ? is_valid_ether_addr() is used at device init time, not when receiving packets. I am not sure we _need_ to check for is_zero_ether_addr() each time we receive a packet. Either a MAC is unicast or multicast. A zero address is not multicast for sure.