Re: [PATCH v2 1/4] Make place for common balloon code
From: Alexander Atanasov <hidden>
Date: 2022-08-18 06:43:42
Also in:
linux-mm, lkml
Hello, On 18.08.22 7:41, Ritesh Harjani wrote:
On 22/08/16 12:41PM, Alexander Atanasov wrote:quoted
File already contains code that is common along balloon drivers so rename it to reflect its contents. mm/balloon_compaction.c -> mm/balloon_common.c Signed-off-by: Alexander Atanasov <redacted> --- MAINTAINERS | 4 ++-- arch/powerpc/platforms/pseries/cmm.c | 2 +- drivers/misc/vmw_balloon.c | 2 +- drivers/virtio/virtio_balloon.c | 2 +- include/linux/{balloon_compaction.h => balloon_common.h} | 2 +- mm/Makefile | 2 +- mm/{balloon_compaction.c => balloon_common.c} | 4 ++--quoted
mm/migrate.c | 2 +- mm/vmscan.c | 2 +-I think we don't need balloon headers in above two files at all. I don't see any references of balloon functions in them.
...
Since I don't often look into this side of code, it's better to confirm :)
Yes, you are right. It passed a visual and compile verification. I will remove them in the next iteration. Thanks for pointing it out :) -- Regards, Alexander Atanasov