Re: [PATCH v2 1/4] Make place for common balloon code
flat view
From: Ritesh Harjani <ritesh.list@gmail.com>
Date: 2022-08-18 04:41:35
Also in:
linux-mm, lkml
On 22/08/16 12:41PM, Alexander Atanasov wrote:
File already contains code that is common along balloon
drivers so rename it to reflect its contents.
mm/balloon_compaction.c -> mm/balloon_common.c
Signed-off-by: Alexander Atanasov <redacted>
---
MAINTAINERS | 4 ++--
arch/powerpc/platforms/pseries/cmm.c | 2 +-
drivers/misc/vmw_balloon.c | 2 +-
drivers/virtio/virtio_balloon.c | 2 +-
include/linux/{balloon_compaction.h => balloon_common.h} | 2 +-
mm/Makefile | 2 +-
mm/{balloon_compaction.c => balloon_common.c} | 4 ++--mm/migrate.c | 2 +- mm/vmscan.c | 2 +-
I think we don't need balloon headers in above two files at all.
I don't see any references of balloon functions in them.
I guess this commit removed it -
commit b1123ea6d3b3da25af5c8a9d843bd07ab63213f4
Author: Minchan Kim [off-list ref]
Date: Tue Jul 26 15:23:09 2016 -0700
mm: balloon: use general non-lru movable page feature
Now, VM has a feature to migrate non-lru movable pages so balloon
doesn't need custom migration hooks in migrate.c and compaction.c.
Instead, this patch implements the page->mapping->a_ops->
{isolate|migrate|putback} functions.
With that, we could remove hooks for ballooning in general migration
functions and make balloon compaction simple.
Since I don't often look into this side of code, it's better to confirm :)
-ritesh