Thread (7 messages) 7 messages, 4 authors, 2022-08-18

Re: [PATCH v2 1/4] Make place for common balloon code

flat view

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2022-08-16 11:22:00
Also in: linux-mm, lkml, virtualization

On Tue, Aug 16, 2022 at 12:41:14PM +0300, Alexander Atanasov wrote:
File already contains code that is common along balloon
drivers so rename it to reflect its contents.
mm/balloon_compaction.c -> mm/balloon_common.c

Signed-off-by: Alexander Atanasov <redacted>
---
 MAINTAINERS                                              | 4 ++--
 arch/powerpc/platforms/pseries/cmm.c                     | 2 +-
 drivers/misc/vmw_balloon.c                               | 2 +-
 drivers/virtio/virtio_balloon.c                          | 2 +-
 include/linux/{balloon_compaction.h => balloon_common.h} | 2 +-
 mm/Makefile                                              | 2 +-
 mm/{balloon_compaction.c => balloon_common.c}            | 4 ++--
 mm/migrate.c                                             | 2 +-
 mm/vmscan.c                                              | 2 +-
 9 files changed, 11 insertions(+), 11 deletions(-)
 rename include/linux/{balloon_compaction.h => balloon_common.h} (99%)
Why rename the .h file?  It still handles the "balloon compaction"
logic.

thanks,

greg k-h
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help