Thread (4 messages) flat view 4 messages, 3 authors, 2021-11-04

Re: [PATCH] powerpc: use swap() to make code cleaner

From: Stephen Rothwell <hidden>
Date: 2021-11-04 20:26:27
Also in: lkml

Hi Segher,

On Thu, 4 Nov 2021 06:33:51 -0500 Segher Boessenkool [off-list ref] wrote:
On Thu, Nov 04, 2021 at 09:06:56PM +1100, Stephen Rothwell wrote:
quoted
On Thu,  4 Nov 2021 14:17:09 +0800 davidcomponentone@gmail.com wrote:  
quoted
From: Yang Guang <redacted>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.  
So if swap() is in the above include file, then you should include it.  
It is included from kernel.h already (which is included from delay.h).
And that becomes a pain when include files get "cleaned up". :-(

$ grep kernel.h include/linux/delay.h
$

See commit

  300424acf349 ("include/linux/delay.h: replace kernel.h with the necessary inclusions")

currently pending the Andrew Morton's patch queue (the above is a
linux-next commit).
-- 
Cheers,
Stephen Rothwell

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help