From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:23
There are three head files(kallsyms.h, kernel.h and sections.h) which
include the kernel sections range check, let's make some cleanup and
unify them.
1. cleanup arch specific text/data check and fix address boundary check
in kallsyms.h
2. make all the basic/core kernel range check function into sections.h
3. update all the callers, and use the helper in sections.h to simplify
the code
After this series, we have 5 APIs about kernel sections range check in
sections.h
* is_kernel_rodata() --- already in sections.h
* is_kernel_core_data() --- come from core_kernel_data() in kernel.h
* is_kernel_inittext() --- come from kernel.h and kallsyms.h
* __is_kernel_text() --- add new internal helper
* __is_kernel() --- add new internal helper
Note: For the last two helpers, people should not use directly, consider to
use corresponding function in kallsyms.h.
v3:
- Add Steven's RB to patch2
- Introduce two internal helper, then use is_kernel_text() in core_kernel_text()
and is_kernel() in kernel_or_module_addr() suggested by Steven
v2:
https://lore.kernel.org/linux-arch/20210728081320.20394-1-wangkefeng.wang@huawei.com/
- add ACK/RW to patch2, and drop inappropriate fix tag
- keep 'core' to check kernel data, suggestted by Steven Rostedt
[off-list ref], rename is_kernel_data() to is_kernel_core_data()
- drop patch8 which is merged
- drop patch9 which is resend independently
v1:
https://lore.kernel.org/linux-arch/20210626073439.150586-1-wangkefeng.wang@huawei.com
Cc: linuxppc-dev@lists.ozlabs.org
Cc: linux-arch@vger.kernel.org
Cc: bpf@vger.kernel.org
Kefeng Wang (9):
kallsyms: Remove arch specific text and data check
kallsyms: Fix address-checks for kernel related range
sections: Move and rename core_kernel_data() to is_kernel_core_data()
sections: Move is_kernel_inittext() into sections.h
x86: mm: Rename __is_kernel_text() to is_x86_32_kernel_text()
sections: Provide internal __is_kernel() and __is_kernel_text() helper
mm: kasan: Use is_kernel() helper
extable: Use is_kernel_text() helper
powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper
arch/powerpc/mm/pgtable_32.c | 7 +---
arch/x86/kernel/unwind_orc.c | 2 +-
arch/x86/mm/init_32.c | 14 +++----
include/asm-generic/sections.h | 75 ++++++++++++++++++++++++++--------
include/linux/kallsyms.h | 13 +-----
include/linux/kernel.h | 2 -
kernel/extable.c | 33 ++-------------
kernel/locking/lockdep.c | 3 --
kernel/trace/ftrace.c | 2 +-
mm/kasan/report.c | 2 +-
net/sysctl_net.c | 2 +-
11 files changed, 75 insertions(+), 80 deletions(-)
--
2.26.2
@@ -34,8 +34,7 @@ static inline int is_kernel_inittext(unsigned long addr)staticinlineintis_kernel_text(unsignedlongaddr){-if((addr>=(unsignedlong)_stext&&addr<=(unsignedlong)_etext)||-arch_is_kernel_text(addr))+if((addr>=(unsignedlong)_stext&&addr<=(unsignedlong)_etext))return1;returnin_gate_area_no_mm(addr);}
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:27
The is_kernel_inittext/is_kernel_text/is_kernel function should not
include the end address(the labels _einittext, _etext and _end) when
check the address range, the issue exists since Linux v2.6.12.
Cc: Arnd Bergmann <arnd@arndb.de>
Cc: Sergey Senozhatsky <redacted>
Cc: Petr Mladek <pmladek@suse.com>
Reviewed-by: Petr Mladek <pmladek@suse.com>
Reviewed-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
Acked-by: Sergey Senozhatsky <senozhatsky@chromium.org>
Signed-off-by: Kefeng Wang <redacted>
---
include/linux/kallsyms.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
@@ -82,24 +82,6 @@ int notrace core_kernel_text(unsigned long addr)return0;}-/**-*core_kernel_data-tellifaddrpointstokerneldata-*@addr:addresstotest-*-*Returnstrueif@addrpassedinisfromthecorekerneldata-*section.-*-*Note:OnsomearchsitmayreturntrueforcoreRODATA,andfalse-*forothers.ButwillalwaysbetrueforcoreRWdata.-*/-intcore_kernel_data(unsignedlongaddr)-{-if(addr>=(unsignedlong)_sdata&&-addr<(unsignedlong)_edata)-return1;-return0;-}-int__kernel_text_address(unsignedlongaddr){if(kernel_text_address(addr))
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:32
The is_kernel_inittext() and init_kernel_text() are with same
functionality, let's just keep is_kernel_inittext() and move
it into sections.h, then update all the callers.
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Thomas Gleixner <redacted>
Cc: Arnd Bergmann <arnd@arndb.de>
Cc: x86@kernel.org
Signed-off-by: Kefeng Wang <redacted>
---
arch/x86/kernel/unwind_orc.c | 2 +-
include/asm-generic/sections.h | 14 ++++++++++++++
include/linux/kallsyms.h | 8 --------
include/linux/kernel.h | 1 -
kernel/extable.c | 12 ++----------
5 files changed, 17 insertions(+), 20 deletions(-)
@@ -62,14 +62,6 @@ const struct exception_table_entry *search_exception_tables(unsigned long addr)returne;}-intinit_kernel_text(unsignedlongaddr)-{-if(addr>=(unsignedlong)_sinittext&&-addr<(unsignedlong)_einittext)-return1;-return0;-}-intnotracecore_kernel_text(unsignedlongaddr){if(addr>=(unsignedlong)_stext&&
@@ -77,7 +69,7 @@ int notrace core_kernel_text(unsigned long addr)return1;if(system_state<SYSTEM_RUNNING&&-init_kernel_text(addr))+is_kernel_inittext(addr))return1;return0;}
@@ -94,7 +86,7 @@ int __kernel_text_address(unsigned long addr)*Sinceweareafterthemodule-symbolscheck,there's*nodangerofaddressoverlap:*/-if(init_kernel_text(addr))+if(is_kernel_inittext(addr))return1;return0;}
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:35
Commit b56cd05c55a1 ("x86/mm: Rename is_kernel_text to __is_kernel_text"),
add '__' prefix not to get in conflict with existing is_kernel_text() in
<linux/kallsyms.h>.
We will add __is_kernel_text() for the basic kernel text range check in the
next patch, so use private is_x86_32_kernel_text() naming for x86 special
check.
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Borislav Petkov <bp@alien8.de>
Cc: x86@kernel.org
Signed-off-by: Kefeng Wang <redacted>
---
arch/x86/mm/init_32.c | 14 +++++---------
1 file changed, 5 insertions(+), 9 deletions(-)
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:41
The core_kernel_text() should check the gate area, as it is part
of kernel text range.
Cc: Steven Rostedt <rostedt@goodmis.org>
Signed-off-by: Kefeng Wang <redacted>
---
kernel/extable.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:43
Use is_kernel_text() and is_kernel_inittext() helper to simplify code,
also drop etext, _stext, _sinittext, _einittext declaration which
already declared in section.h.
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: linuxppc-dev@lists.ozlabs.org
Signed-off-by: Kefeng Wang <redacted>
---
arch/powerpc/mm/pgtable_32.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
From: Kefeng Wang <hidden> Date: 2021-09-26 07:18:45
An internal __is_kernel() helper which only check the kernel address ranges,
and an internal __is_kernel_text() helper which only check text section ranges.
Signed-off-by: Kefeng Wang <redacted>
---
include/asm-generic/sections.h | 29 +++++++++++++++++++++++++++++
include/linux/kallsyms.h | 4 ++--
2 files changed, 31 insertions(+), 2 deletions(-)
Use is_kernel_text() and is_kernel_inittext() helper to simplify code,
also drop etext, _stext, _sinittext, _einittext declaration which
already declared in section.h.
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: linuxppc-dev@lists.ozlabs.org
Signed-off-by: Kefeng Wang <redacted>
---
arch/powerpc/mm/pgtable_32.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
From: Kefeng Wang <hidden> Date: 2021-09-29 01:14:37
On 2021/9/29 1:51, Christophe Leroy wrote:
Le 26/09/2021 à 09:20, Kefeng Wang a écrit :
quoted
Use is_kernel_text() and is_kernel_inittext() helper to simplify code,
also drop etext, _stext, _sinittext, _einittext declaration which
already declared in section.h.
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: linuxppc-dev@lists.ozlabs.org
Signed-off-by: Kefeng Wang <redacted>
---
arch/powerpc/mm/pgtable_32.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)