kasan · Maintained
Maintainers
- M Andrey Ryabinin <ryabinin.a.a@gmail.com>
- R Alexander Potapenko <glider@google.com>
- R Andrey Konovalov <andreyknvl@gmail.com>
- R Dmitry Vyukov <dvyukov@google.com>
- R Vincenzo Frascino <vincenzo.frascino@arm.com>
Paths
- F
Documentation/dev-tools/kasan.rst - F
arch/*/include/asm/*kasan.h - F
arch/*/mm/kasan_init* - F
include/linux/kasan*.h - F
lib/Kconfig.kasan - F
mm/kasan/ - F
scripts/Makefile.kasan
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linuxppc-dev (capped at 30), ordered by date desc.
-
COOLING4d
[PATCH v15 7/9] arm64: introduce copy_mc_to_kernel() implementation
2026-06-18 · Ruidong Tian <hidden> -
COLD31d
[PATCH v14 7/8] arm64: introduce copy_mc_to_kernel() implementation
2026-05-18 · Ruidong Tian <hidden> -
STALE68d
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE112d
Re: [PATCH v5 14/15] mm/kasan: add document into kernel-parameters.txt
2026-03-17 · Baoquan He <hidden> -
STALE112d
[PATCH v5 15/15] mm/kasan: clean up unneeded ARCH_DEFER_KASAN and kasan_arch_is_ready
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 14/15] mm/kasan: add document into kernel-parameters.txt
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 05/15] mm/kasan/sw_tags: don't initialize kasan if it's disabled
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 04/15] mm/kasan: make kasan=on|off take effect for all three modes
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 03/15] mm/kasan: mm/kasan: move kasan= code to common place
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 02/15] mm/kasan: rename 'kasan_arg' to 'kasan_arg_disabled'
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 01/15] mm/kasan: add conditional checks in functions to return directly if kasan is disabled
2026-02-25 · Baoquan He <hidden> -
STALE118d
[PATCH v2] mm/kasan: Fix double free for kasan pXds
2026-02-24 · "Ritesh Harjani (IBM)" <ritesh.list@gmail.com> -
STALE173d
REVIEWED: 2 (0M) [PATCH v6 07/14] mm: introduce generic lazy_mmu helpers
2025-12-15 · Kevin Brodsky <hidden> -
STALE213d
REVIEWED: 1 (0M) [PATCH v5 06/12] mm: introduce generic lazy_mmu helpers
2025-11-24 · Kevin Brodsky <hidden> -
STALE224d
[PATCH v4 06/12] mm: introduce generic lazy_mmu helpers
2025-10-29 · Kevin Brodsky <hidden> -
STALE251d
[PATCH v3 06/13] mm: introduce generic lazy_mmu helpers
2025-10-15 · Kevin Brodsky <hidden> -
STALE294d
REVIEWED: 11 (11M) [PATCH v2 2/7] mm: introduce local state for lazy_mmu sections
2025-09-08 · Kevin Brodsky <hidden> -
DORMANTno replies
[PATCH 4/4] mm/kasan: remove kasan_arch_is_ready()
2025-08-12 · Baoquan He <hidden> -
STALE270d
[PATCH v6 1/2] kasan: introduce ARCH_DEFER_KASAN and unify static key across modes
2025-08-10 · Sabyrzhan Tasbolatov <hidden> -
STALE330d
[PATCH v5 1/2] kasan: introduce ARCH_DEFER_KASAN and unify static key across modes
2025-08-07 · Sabyrzhan Tasbolatov <hidden> -
STALE334d
[PATCH v4 1/9] kasan: introduce ARCH_DEFER_KASAN and unify static key across modes
2025-08-05 · Sabyrzhan Tasbolatov <hidden> -
STALE336d
Re: [PATCH v3 00/12] kasan: unify kasan_arch_is_ready() and remove arch-specific implementations
2025-08-03 · Sabyrzhan Tasbolatov <hidden> -
STALE336d
[PATCH v3 12/12] kasan: add shadow checks to wrappers and rename kasan_arch_is_ready
2025-07-17 · Sabyrzhan Tasbolatov <hidden> -
STALE336d
[PATCH v3 02/12] kasan: unify static kasan_flag_enabled across modes
2025-07-17 · Sabyrzhan Tasbolatov <hidden> -
STALE336d
[PATCH v3 01/12] lib/kasan: introduce CONFIG_ARCH_DEFER_KASAN option
2025-07-17 · Sabyrzhan Tasbolatov <hidden> -
STALE370d
Re: [PATCH v2 00/11] kasan: unify kasan_arch_is_ready with kasan_enabled
2025-07-01 · Heiko Carstens <hca@linux.ibm.com> -
STALE370d
Re: [PATCH v2 00/11] kasan: unify kasan_arch_is_ready with kasan_enabled
2025-06-28 · Christophe Leroy <hidden> -
STALE370d
[PATCH v2 11/11] kasan: replace kasan_arch_is_ready with kasan_enabled
2025-06-26 · Sabyrzhan Tasbolatov <hidden> -
STALE370d
[PATCH v2 01/11] kasan: unify static kasan_flag_enabled across modes
2025-06-26 · Sabyrzhan Tasbolatov <hidden> -
STALE375d
[PATCH 2/9] kasan: replace kasan_arch_is_ready with kasan_enabled
2025-06-25 · Sabyrzhan Tasbolatov <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE112d
[PATCH v5 01/15] mm/kasan: add conditional checks in functions to return directly if kasan is disabled
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 02/15] mm/kasan: rename 'kasan_arg' to 'kasan_arg_disabled'
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 03/15] mm/kasan: mm/kasan: move kasan= code to common place
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 04/15] mm/kasan: make kasan=on|off take effect for all three modes
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 05/15] mm/kasan/sw_tags: don't initialize kasan if it's disabled
2026-02-25 · Baoquan He <hidden> -
STALE112d
[PATCH v5 15/15] mm/kasan: clean up unneeded ARCH_DEFER_KASAN and kasan_arch_is_ready
2026-02-25 · Baoquan He <hidden>