tracing · Maintained
Maintainers
- M Steven Rostedt <rostedt@goodmis.org>
- M Masami Hiramatsu <mhiramat@kernel.org>
- R Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Paths
- F
Documentation/core-api/tracepoint.rst - F
Documentation/trace/* - F
fs/tracefs/ - F
include/linux/trace*.h - F
include/trace/ - F
kernel/trace/ - F
kernel/tracepoint.c - F
scripts/tracing/ - F
scripts/tracepoint-update.c - F
tools/testing/selftests/ftrace/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linuxppc-dev (capped at 30), ordered by date desc.
-
COLD28d
IN LINUX-NEXT: 6 (6M) [PATCH v8 09/23] dma-mapping: Add internal shared allocation attribute
2026-07-17 · "Aneesh Kumar K.V (Arm)" <aneesh.kumar@kernel.org> -
COLD53d
[PATCH v7 09/22] dma-mapping: Add internal shared allocation attribute
2026-07-01 · "Aneesh Kumar K.V (Arm)" <aneesh.kumar@kernel.org> -
STALE67d
REVIEWED: 9 (9M) [PATCH v4 1/2] tracing: Move non-trace_printk prototypes into trace_controls.h
2026-06-25 · Steven Rostedt <rostedt@kernel.org> -
STALE67d
REVIEWED: 9 (9M) [PATCH v4 2/2] tracing: Remove trace_printk.h from kernel.h
2026-06-25 · Steven Rostedt <rostedt@kernel.org> -
STALE68d
[PATCH 2/2] tracing: Add CONFIG_TRACE_PRINTK_DEBUGGING to clean up kernel.h
2026-06-21 · Steven Rostedt <rostedt@kernel.org> -
STALE219d
REVIEWED: 17 (17M) [PATCH v4 19/54] convert tracefs
2025-11-18 · Al Viro <viro@zeniv.linux.org.uk> -
STALE219d
REVIEWED: 17 (17M) [PATCH v4 02/54] tracefs: fix a leak in eventfs_create_events_dir()
2025-11-18 · Al Viro <viro@zeniv.linux.org.uk> -
STALE294d
REVIEWED: 17 (17M) [PATCH v3 02/50] tracefs: fix a leak in eventfs_create_events_dir()
2025-11-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE294d
REVIEWED: 17 (17M) [PATCH v3 19/50] convert tracefs
2025-11-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE286d
[PATCH v2 19/50] convert tracefs
2025-10-28 · Al Viro <viro@zeniv.linux.org.uk> -
STALE286d
[PATCH v2 02/50] tracefs: fix a leak in eventfs_create_events_dir()
2025-10-28 · Al Viro <viro@zeniv.linux.org.uk> -
STALE348d
[PATCH 17/39] convert tracefs
2025-09-20 · Al Viro <viro@zeniv.linux.org.uk> -
STALE349d
LANDED: 7 (7M) [PATCH v6 11/16] dma-mapping: export new dma_*map_phys() interface
2025-09-09 · Leon Romanovsky <leon@kernel.org> -
STALE349d
LANDED: 6 (6M) [PATCH v6 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-09-09 · Leon Romanovsky <leon@kernel.org> -
STALE349d
LANDED: 6 (6M) [PATCH v6 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
2025-09-09 · Leon Romanovsky <leon@kernel.org> -
STALE367d
REVIEWED: 7 (7M) [PATCH v5 11/16] dma-mapping: export new dma_*map_phys() interface
2025-09-02 · Leon Romanovsky <leon@kernel.org> -
STALE367d
REVIEWED: 6 (6M) [PATCH v5 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-09-02 · Leon Romanovsky <leon@kernel.org> -
STALE367d
REVIEWED: 6 (6M) [PATCH v5 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
2025-09-02 · Leon Romanovsky <leon@kernel.org> -
STALE354d
LANDED: 1 (0M) [PATCH v2 2/4] copy_process: pass clone_flags as u64 across calltree
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE364d
[PATCH v4 11/16] dma-mapping: export new dma_*map_phys() interface
2025-08-19 · Leon Romanovsky <leon@kernel.org> -
STALE364d
[PATCH v4 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-08-19 · Leon Romanovsky <leon@kernel.org> -
STALE364d
[PATCH v4 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
2025-08-19 · Leon Romanovsky <leon@kernel.org> -
STALE387d
[PATCH v3 11/16] dma-mapping: export new dma_*map_phys() interface
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE387d
[PATCH v3 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE387d
[PATCH v3 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE389d
[PATCH v2 11/16] dma-mapping: export new dma_*map_phys() interface
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE389d
[PATCH v2 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE389d
[PATCH v2 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory
2025-08-14 · Leon Romanovsky <leon@kernel.org> -
STALE389d
[PATCH v1 11/16] dma-mapping: export new dma_*map_phys() interface
2025-08-04 · Leon Romanovsky <leon@kernel.org> -
STALE389d
[PATCH v1 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys
2025-08-04 · Leon Romanovsky <leon@kernel.org>