Re: Re: [PATCH 1/3] arm64: mm: Add p?d_large() definitions
From: Will Deacon <will@kernel.org>
Date: 2019-07-02 10:46:31
Also in:
linux-arm-kernel, linux-mm
From: Will Deacon <will@kernel.org>
Date: 2019-07-02 10:46:31
Also in:
linux-arm-kernel, linux-mm
On Tue, Jul 02, 2019 at 01:07:11PM +1000, Nicholas Piggin wrote:
Will Deacon's on July 1, 2019 8:15 pm:quoted
On Mon, Jul 01, 2019 at 11:03:51AM +0100, Steven Price wrote:quoted
On 01/07/2019 10:27, Will Deacon wrote:quoted
On Sun, Jun 23, 2019 at 07:44:44PM +1000, Nicholas Piggin wrote:quoted
walk_page_range() is going to be allowed to walk page tables other than those of user space. For this it needs to know when it has reached a 'leaf' entry in the page tables. This information will be provided by the p?d_large() functions/macros.I can't remember whether or not I asked this before, but why not call this macro p?d_leaf() if that's what it's identifying? "Large" and "huge" are usually synonymous, so I find this naming needlessly confusing based on this patch in isolation.Those page table macro names are horrible. Large, huge, leaf, wtf? They could do with a sensible renaming. But this series just follows naming that's alreay there on x86.
I realise that, and I wasn't meaning to have a go at you. Just wanted to make my opinion clear by having a moan :) Will