On Mon, Feb 26, 2018 at 4:44 PM, Andy Shevchenko
[off-list ref] wrote:
On Sun, Feb 25, 2018 at 7:22 PM, Mathieu Malaterre [off-list ref] wrote:
quoted
static void __init check_cpu_feature_properties(unsigned long node)
{
- unsigned long i;
struct feature_property *fp = feature_properties;
const __be32 *prop;
Much simpler is just add
if (ARRAY_SIZE() == 0)
return;
quoted
- for (i = 0; i < ARRAY_SIZE(feature_properties); ++i, ++fp) {
+ for (; fp != feature_properties + ARRAY_SIZE(feature_properties); ++fp) {
...or convert to while(), which will be more readable.
--
With Best Regards,
Andy Shevchenko