Thread (23 messages) flat view 23 messages, 4 authors, 2015-07-22

Re: [RFC,2/8] powerpc/slb: Rename all the 'entry' occurrences to 'slot'

From: Anshuman Khandual <hidden>
Date: 2015-07-21 11:23:24

On 07/21/2015 03:16 PM, Michael Ellerman wrote:
On Tue, 2015-21-07 at 06:58:40 UTC, Anshuman Khandual wrote:
quoted
quoted
From: "khandual@linux.vnet.ibm.com" <redacted>

These are essentially SLB individual slots what we are dealing with
in these functions. Usage of both 'entry' and 'slot' synonyms makes
it real confusing sometimes. This patch makes it uniform across the
file by replacing all those 'entry's with 'slot's.
No I think it would be better the other way around.

Currently we use entry in 14 places and slot in 3.

Both can be correct in some places, but not always.

For example:
quoted
quoted
-	 * Clear the ESID first so the entry is not valid while we are
+	 * Clear the ESID first so the slot is not valid while we are
That doesn't make sense with "slot", a slot is not valid, only an entry in a
slot is valid.

Looking at the existing uses of slot they will all make sense if you change
them to entry.
Sure, yeah will do the other way around.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help