Re: [RFC] [PATCH] powerpc: Add MSR_DE to MSR_KERNEL
From: Joakim Tjernlund <hidden>
Date: 2012-06-01 10:38:47
Benjamin Herrenschmidt [off-list ref] wrote on 2012/06/01 11:14:49:
On Wed, 2012-05-30 at 09:26 -0400, Bob Cochran wrote:quoted
I believe that additional patches are required for CodeWarrior to work properly (e.g., assembly start up). I think the patches should come from Freescale. For whatever reason, they include them in their SDK, but haven't submitted them for inclusion in the mainline. As a developer on Freescale Power products, I would like to see Freescale offer up a CodeWarrior patch set, so I don't have to manage the patches myself when working outside the SDK (i.e., on a more recent kernel).Such patches would have a hard time getting upstream considering that codewarrior is a commercial product.
Naa, Abatron BDI is also a commercial product and that is in the kernel. CW changes pretty much just add the same settings for CONFIG_CW. I think Freescale should just rename CONFIG_BDI_SWITCH to something generic and just use the same code. Jocke