Re: [PATCH] [POWERPC] Move generic MPC82xx functions out of ADS-specific
From: Laurent Pinchart <hidden>
Date: 2007-07-12 15:04:48
Hi Scott, On Wednesday 11 July 2007 17:25, Scott Wood wrote:
Laurent Pinchart wrote:quoted
On Tuesday 10 July 2007 20:05, Scott Wood wrote:quoted
Why are you also moving mpc82xx_ads_show_cpuinfo() to the board file? It's not really ADS-specific; it should just be renamed.For the MPC82xx ADS boards, mpc82xx_ads_show_cpuinfo() prints Vendor : Freescale Semiconductor Machine : PQ2 ADS PowerPC The vendor string is hardcoded to "Freescale Semiconductor", and the machine string is defined in pq2ads.h. What should show_cpuinfo() print ? Should the vendor be the board vendor or the CPU vendor ? What about the machine ?Ah, I missed that. I'd just get rid of "Vendor" altogether, and include the vendor name in the machine name.
Is there any standard/documentation regarding what show_cpuinfo should print ? Should it show CPU information only, or board information as well ? What about the memory size, clock settings, ... ? What are the meanings of "vendor" and "machine" ? -- Laurent Pinchart CSE Semaphore Belgium