Thread (8 messages) flat view 8 messages, 5 authors, 2007-07-13

Re: [PATCH] [POWERPC] Move generic MPC82xx functions out of ADS-specific

From: Laurent Pinchart <hidden>
Date: 2007-07-11 07:28:59

On Tuesday 10 July 2007 20:05, Scott Wood wrote:
On Tue, Jul 10, 2007 at 01:12:45PM +0200, Laurent Pinchart wrote:
quoted
The non board-specific mpc82xx_halt and mpc82xx_restart functions are
defined in arch/powerpc/platforms/82xx/mpc82xx_ads.c. This patch moves
them to mpc82xx.c to make them usable by other MPC82xx boards.
Why are you also moving mpc82xx_ads_show_cpuinfo() to the board file?
It's not really ADS-specific; it should just be renamed.
For the MPC82xx ADS boards, mpc82xx_ads_show_cpuinfo() prints

Vendor		: Freescale Semiconductor
Machine		: PQ2 ADS PowerPC

The vendor string is hardcoded to "Freescale Semiconductor", and the machine 
string is defined in pq2ads.h. What should show_cpuinfo() print ? Should the 
vendor be the board vendor or the CPU vendor ? What about the machine ?

Laurent Pinchart
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help