Laurent Pinchart wrote:
On Tuesday 10 July 2007 20:05, Scott Wood wrote:
quoted
Why are you also moving mpc82xx_ads_show_cpuinfo() to the board file?
It's not really ADS-specific; it should just be renamed.
For the MPC82xx ADS boards, mpc82xx_ads_show_cpuinfo() prints
Vendor : Freescale Semiconductor
Machine : PQ2 ADS PowerPC
The vendor string is hardcoded to "Freescale Semiconductor", and the machine
string is defined in pq2ads.h. What should show_cpuinfo() print ? Should the
vendor be the board vendor or the CPU vendor ? What about the machine ?
Ah, I missed that. I'd just get rid of "Vendor" altogether, and include
the vendor name in the machine name.
-Scott