At Wed, 07 Jun 2006 13:40:21 +0200,
Johannes Berg wrote:
On Tue, 2006-06-06 at 16:00 +0200, Takashi Iwai wrote:
quoted
quoted
Yeah, I guess, never really thought about that, just wrote it down the
way I thought to do it :) That said, I think it's more readable if
written that way, do you want me to change it regardless?
I found a single if is more readable (and good for compiler).
Heh ok, I'll change it, it isn't really hard to read either way.
quoted
No, the only requirement is that you have to call snd_pcm_lib_malloc()
with proper type and assigned device pointer if you use
snd_pcm_lib_malloc() function. (If not called, you've got an error
when compiled with debug option.)
Ok, but how do I set the device pointer?
Your code already does it. The macro pci_to_dev() retrieves struct
device pointer (it's just for compatibility with older kernels).
Takashi