Thread (32 messages) flat view 32 messages, 3 authors, 2006-06-07

Re: [Alsa-devel] [RFC 4/8] snd-aoa: add i2sbus

From: Johannes Berg <johannes@sipsolutions.net>
Date: 2006-06-07 11:40:42
Also in: alsa-devel

On Tue, 2006-06-06 at 16:00 +0200, Takashi Iwai wrote:
quoted
Yeah, I guess, never really thought about that, just wrote it down the
way I thought to do it :) That said, I think it's more readable if
written that way, do you want me to change it regardless?
I found a single if is more readable (and good for compiler).
Heh ok, I'll change it, it isn't really hard to read either way.

No, the only requirement is that you have to call snd_pcm_lib_malloc()
with proper type and assigned device pointer if you use
snd_pcm_lib_malloc() function.  (If not called, you've got an error
when compiled with debug option.)
Ok, but how do I set the device pointer?

johannes

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help