CONFIG_ALL_PPC

10 messages, 8 authors, 2001-11-29 · open the first message on its own page

CONFIG_ALL_PPC

From: Paul Mackerras <hidden>
Date: 2001-11-28 22:07:12

I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?

Paul.

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Tom Gall <hidden>
Date: 2001-11-28 22:15:26

Paul Mackerras wrote:
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?
Hmmm well not that I object because I don't... but I am working on this POP
board here and technically speaking it's the next in the great PREP / PMAC /
CHRP chain...

CONFIG_PREP_PMAC_CHRP_POP?  ICK!

I'm hopeful in the end it'll fall into the CHRP catagory but some of these
firmware differences could be a bear to resolve. But I might be a little
over-alarmist too...

Regards,

Tom
Paul.
--
Tom Gall - [embedded] [PPC64 | PPC32] Code Monkey
Peace, Love &                  "Where's the ka-boom? There was
Linux Technology Center         supposed to be an earth
http://www.ibm.com/linux/ltc/   shattering ka-boom!"
(w) tom_gall@vnet.ibm.com       -- Marvin Martian
(w) 507-253-4558
(h) tgall@rochcivictheatre.org

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date: 2001-11-28 22:19:28

Hmmm well not that I object because I don't... but I am working on this POP
board here and technically speaking it's the next in the great PREP / PMAC /
CHRP chain...

CONFIG_PREP_PMAC_CHRP_POP?  ICK!

I'm hopeful in the end it'll fall into the CHRP catagory but some of these
firmware differences could be a bear to resolve. But I might be a little
over-alarmist too...
It's a difficult choice ;)

What about CONFIG_COMMON_PPC ? Still a bit misleading, but probably
better than CONFIG_ALL_PPC...

Ben.


** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Timothy A. Seufert <hidden>
Date: 2001-11-28 22:28:33

At 10:15 PM +0000 11/28/01, Tom Gall wrote:
Paul Mackerras wrote:
quoted
 I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
 linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
 use that).

 Does anyone object to this?
Hmmm well not that I object because I don't... but I am working on this POP
board here and technically speaking it's the next in the great PREP / PMAC /
CHRP chain...

CONFIG_PREP_PMAC_CHRP_POP?  ICK!
How about CONFIG_AIM or similar (referencing the three combatants in
the PPC platform wars)?
--
Tim Seufert

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Michel Dänzer <hidden>
Date: 2001-11-28 23:30:22

On Wed, 2001-11-28 at 23:07, Paul Mackerras wrote:
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).
CONFIG_ALL_PPC_MINUS_APUS? ;)


--
Earthling Michel Dänzer (MrCooper)/ Debian GNU/Linux (powerpc) developer
XFree86 and DRI project member   /  CS student, Free Software enthusiast

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Paul Mackerras <hidden>
Date: 2001-11-28 23:34:51

Benjamin Herrenschmidt writes:
It's a difficult choice ;)

What about CONFIG_COMMON_PPC ? Still a bit misleading, but probably
better than CONFIG_ALL_PPC...
You know, what I am really tempted to do is to split out prep again
and have a CONFIG_PPC_OPENFIRMWARE to indicate pmac and chrp and
anything else that has a working OF.  But Olaf would kill me... :)

Paul.

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Tom Rini <hidden>
Date: 2001-11-28 23:43:06

On Thu, Nov 29, 2001 at 09:07:12AM +1100, Paul Mackerras wrote:
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?
Yes.  For historical note, the old 2_5 tree had CONFIG_WORKSTATION_PPC,
which suited most people.  But there's the fact that most of the
7xx/74xx boards in _devel now can take a video card and be a
'workstation' too. :)

How about we don't do this in 2_4 (or 2_4_devel) at all since it'll be a
bit of a maintance headache (2.4.x, x <= A is CONFIG_ALL_PPC, > A might
be XXX or ALL_PPC, and >= B it got into kernel.org, ick..).

Perhaps we could even go as far as doing CONFIG_OPENFIRMWARE_PPC for
chrp/pmac/pop, bring back CONFIG_PREP for 'PReP', and work on doing
plaform support along the lines of Y/N instead of group A, B, or C.

Or barring all of that messy work, CONFIG_COMMON_PPC :)

--
Tom Rini (TR1265)
http://gate.crashing.org/~trini/

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: 2001-11-29 08:26:19

On Wed, 28 Nov 2001, Tom Gall wrote:
Paul Mackerras wrote:
quoted
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?
Hmmm well not that I object because I don't... but I am working on this POP
board here and technically speaking it's the next in the great PREP / PMAC /
CHRP chain...
Is this a revive of the POP-boards or a we-still-have-a-few-prototypes-lying-
around-so-let-us-port-Linux-to-it event?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds


** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Gabriel Paubert <hidden>
Date: 2001-11-29 08:36:02

On Wed, 28 Nov 2001, Tom Rini wrote:
On Thu, Nov 29, 2001 at 09:07:12AM +1100, Paul Mackerras wrote:
quoted
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?
Yes.  For historical note, the old 2_5 tree had CONFIG_WORKSTATION_PPC,
which suited most people.  But there's the fact that most of the
7xx/74xx boards in _devel now can take a video card and be a
'workstation' too. :)
Right. But even older ones, for example I have MVME boards with PMC video
modules (that's _the_ reason for which I wrote a x86 BIOS ROM emulator,
which will hopefully end up one day in the source tree) which are almost
5 years old.

MVME boards for example are not workstation and yet are PreP or OF-less
CHRP. Why not doing it the other way around, or at least not presenting
the option in the configuration: if you don't select a specific machine,
set CONFIG_{ALL,COMMON,VULGAR,GENERIC}_PPC (pick te one you prefer, I'm
not a native english speaker).

Of course you could also invert the "polarity" of the definition, although
having to select the CONFIG_ELITIST_PPC to specify a non Pmac/PreP/CHRP
machine might not sound politically correct to some people :-)
CONFIG_SPECIFIC_PPC does not sound that bad, however.

[The following is a message from Tom on July 5th, I had started to answer
and then it got lost in a long list of postponed-msgs: it's the day my
second son was born :-)]
quoted
Which leads me to ask what are the advantages of making gemini part of
CONFIG_ALL_PPC?  Is it that gemini is sufficiently close to a prep
that we might as well treat it as a prep?
I'm definatly not an expert on the boards, but, iirc, they're as 'PReP' as
many of the ports in 2_4_devel.  They're not 100% compliant, but they
could work, but sub-optimally.
It's hard to tell which boards are 100% PreP compliant, given the
fuzzyness of the specification.

	Regards,
	Gabriel.


** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

Re: CONFIG_ALL_PPC

From: Tom Gall <hidden>
Date: 2001-11-29 17:05:37

Geert Uytterhoeven wrote:
On Wed, 28 Nov 2001, Tom Gall wrote:
quoted
Paul Mackerras wrote:
quoted
I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
use that).

Does anyone object to this?
Hmmm well not that I object because I don't... but I am working on this POP
board here and technically speaking it's the next in the great PREP / PMAC /
CHRP chain...
Is this a revive of the POP-boards or a we-still-have-a-few-prototypes-lying-
around-so-let-us-port-Linux-to-it event?
Real product in this case. It has a GA (general availability) date and
everything.
Gr{oetje,eeting}s,
Regards,

Tom

--
Tom Gall - [embedded] [PPC64 | PPC32] Code Monkey
Peace, Love &                  "Where's the ka-boom? There was
Linux Technology Center         supposed to be an earth
http://www.ibm.com/linux/ltc/   shattering ka-boom!"
(w) tom_gall@vnet.ibm.com       -- Marvin Martian
(w) 507-253-4558
(h) tgall@rochcivictheatre.org

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help