On Fri, 2017-06-16 at 05:04 -0700, Joe Perches wrote:
Perhaps
skb_put_data(skb, &c, sizeof(c))
as that avoids api expansion.
Doing this means putting c on the stack first in many places so a
pointer can be taken, which isn't nice.
Optimizing the indirections and the size in a macro front-end
in skb_put_data may be better as it's would be completely
consistent for all use styles.
Well, you'd still have to worry about aligned/unaligned for anything
bigger than 1 byte, so ...
My bikeshedding on this is over, I'll send out all these (now 6)
patches again once I have a build result from the 0-day bot, and unless
Dave wants to have specific changes I've already spent enough time.
johannes