Thread (20 messages) 20 messages, 4 authors, 2016-09-26

Re: [PATCH v2 RESEND] qtnfmac: announcement of new FullMAC driver for Quantenna chipsets

From: Kalle Valo <hidden>
Date: 2016-09-26 10:45:56

IgorMitsyanko [off-list ref] writes:
On 09/17/2016 04:56 PM, Kalle Valo wrote:
quoted
[off-list ref] writes:
quoted
+/* FW names */
+
+#define QTN_PCI_FW_NAME		"pearl-linux.lzma.img"
The firmware name gives no indication what this file is about (remember
that linux-firmware.git has a lot of files). Please name it properly,
don't just use what is used in by firmware build scripts :) Take into
account also future hw support, all firmware files need to coexist in
the same repository without user invention. In a way the firmware
filename is part of kernel/userspace interface and needs to be stable.

For example, you could use something like "qtnfmac/qsr10g.img" (assuming
qsr10g is the name of chip).
Ok, we will reconsider our naming conventions, take into account more
devices that we need to support in the future.
I'm thinking about something like:
qtn/fmac_qsr10g.img  <---- FullMAC QSR10G device
qtn/fmac_qsr1000.img  <---- FullMAC QSR1000 device
qtn/smac_qsr10g.img  <---- SoftMAC QSR10G
qtn/smac_qsr10000.img <----- SoftMAC QSR1000
etc
Looks good to me.

-- 
Kalle Valo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help