Re: [PATCH 38/80] staging: wilc1000: rename au8Bssid of struct ba_session_info
From: Joe Perches <joe@perches.com>
Date: 2015-10-28 17:06:25
On Wed, 2015-10-28 at 19:56 +0300, Dan Carpenter wrote:
On Wed, Oct 28, 2015 at 03:59:58PM +0900, Glen Lee wrote:quoted
From: Leo Kim <redacted> This patch renames au8Bssid of struct ba_session_info to bssid to avoid CamelCase naming convention. And, some debug logs modified because 80 ending line over warnings.
Don't worry about some 80 column warnings.
quoted
diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c
[]
quoted
@@ -2715,10 +2715,14 @@ static s32 Handle_AddBASession(struct host_if_drv *hif_drv, int AddbaTimeout = 100; char *ptr = NULL; - PRINT_D(HOSTINF_DBG, "Opening Block Ack session with\nBSSID = %.2x:%.2x:%.2x\nTID=%d\nBufferSize == %d\nSessionTimeOut = %d\n", - strHostIfBASessionInfo->au8Bssid[0], - strHostIfBASessionInfo->au8Bssid[1], - strHostIfBASessionInfo->au8Bssid[2], + PRINT_D(HOSTINF_DBG, "Opening Block Ack session with \ + \nBSSID = %.2x:%.2x:%.2x \ + \nBufferSize == %d \ + \nSessionTimeOut = %d \ + \nTID=%d\n", + strHostIfBASessionInfo->bssid[0], + strHostIfBASessionInfo->bssid[1], + strHostIfBASessionInfo->bssid[2], strHostIfBASessionInfo->u16BufferSize, strHostIfBASessionInfo->u16SessionTimeout, strHostIfBASessionInfo->u8Ted);This should be a bunch of printks so that we have the correct debug level at the start of each line.
Also, don't use continuation \ as this adds undesired whitespace for each new line Realistically, this should just be a single line output. PRINT_D(HOSTINF_DBG, "Opening Block Ack session with BSSID = %02x:%02x:%02x TID=%d BufferSize == %d SessionTimeOut = %d\n", etc... But why are only 3 bytes of the bssid desired/emitted?