Xiaoyao Li [off-list ref] writes:
On 8/10/2026 11:01 PM, Sean Christopherson wrote:
quoted
quoted
As mentioned in v9, the name is confusing.
kvm_gmem_mem_is_private
?
Ya, +1 to kvm_gmem_mem_is_private.
So kvm_gmem_mem_is_private() calls kvm_gmem_is_private_mem()
internallly. Ummmm.
How about
kvm_gmem_mem_is_private(kvm, gfn)
__gmem_mem_is_private(inode, index) <== this is a static function
anyway, though it calls
kvm_gmem_get_attributes(inode, entry)
or
kvm_gmem_gfn_is_private(kvm, gfn)
kvm_gmem_is_private_mem(inode, index)
(rename the vm stuff with the suffix gfn_is_private())
or (current, it is actually weird)
kvm_gmem_mem_is_private(kvm, gfn)
kvm_gmem_is_private_mem(inode, index)
or
kvm_gmem_mem_is_private(kvm, gfn)
kvm_gmem_index_is_private(inode, index)