Hi Steve,
On Wed, 2025-05-07 at 10:53 -0400, Steven Rostedt wrote:
These are minor clean ups of the trace_events_trigger code.
- Rename event_trigger_alloc() to trigger_data_alloc() as it
is supposed to be freed by trigger_data_free().
- Remove unneeded goto outs
- Add consistent cleanup in event_trigger_parse()
Miaoqian Lin (1):
tracing: Fix error handling in event_trigger_parse()
Steven Rostedt (2):
tracing: Rename event_trigger_alloc() to trigger_data_alloc()
tracing: Remove unnecessary "goto out" that simply returns ret
is trigger code
These all look right to me, and were probably the original intent.
For all 3,
Reviewed-by: Tom Zanussi <zanussi@kernel.org>
Thanks,
Tom
----
kernel/trace/trace.h | 8 ++---
kernel/trace/trace_events_hist.c | 2 +-
kernel/trace/trace_events_trigger.c | 64 ++++++++++++++++-----------
----------
3 files changed, 31 insertions(+), 43 deletions(-)