Thread (6 messages) flat view 6 messages, 2 authors, 2025-05-12
STALE451d

[PATCH 0/3] tracing: Some cleanups of event trigger code

From: Steven Rostedt <rostedt@goodmis.org>
Date: 2025-05-07 14:54:45
Also in: lkml

These are minor clean ups of the trace_events_trigger code.

- Rename event_trigger_alloc() to trigger_data_alloc() as it
  is supposed to be freed by trigger_data_free().

- Remove unneeded goto outs

- Add consistent cleanup in event_trigger_parse()


Miaoqian Lin (1):
      tracing: Fix error handling in event_trigger_parse()

Steven Rostedt (2):
      tracing: Rename event_trigger_alloc() to trigger_data_alloc()
      tracing: Remove unnecessary "goto out" that simply returns ret is trigger code

----
 kernel/trace/trace.h                |  8 ++---
 kernel/trace/trace_events_hist.c    |  2 +-
 kernel/trace/trace_events_trigger.c | 64 ++++++++++++++++---------------------
 3 files changed, 31 insertions(+), 43 deletions(-)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help