Re: [PATCH v2 01/12] md/raid5: Factor out ahead_of_reshape() function
From: Wol <hidden>
Date: 2022-04-21 23:33:45
Also in:
lkml
From: Wol <hidden>
Date: 2022-04-21 23:33:45
Also in:
lkml
On 21/04/2022 17:05, Logan Gunthorpe wrote:
quoted
I like the ternary operator.;-) return mddev->reshape_backwards ? (return sector < reshape_sector) : (sector >= reshape_sector) Sorry, does not matter.Yeah, I think plenty of people do not, though; it's harder to read with the long line and awkward to wrap.
I like the ternary too, but is there a superfluous return in there? That would shorten the line. Or break it on the question mark - condition, true, false all on their own lines. Cheers, Wol