Thread (25 messages) 25 messages, 5 authors, 2021-06-01

Re: [PATCH 6/8] block: move bd_part_count to struct gendisk

From: Hannes Reinecke <hare@suse.de>
Date: 2021-05-25 08:20:59
Also in: linux-block, linux-s390, linux-scsi

On 5/25/21 8:12 AM, Christoph Hellwig wrote:
The bd_part_count value only makes sense for whole devices, so move it
to struct gendisk and give it a more descriptive name.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
  block/ioctl.c             | 2 +-
  fs/block_dev.c            | 6 +++---
  include/linux/blk_types.h | 3 ---
  include/linux/genhd.h     | 1 +
  4 files changed, 5 insertions(+), 7 deletions(-)
Reviewed-by: Hannes Reinecke <hare@suse.de>

Cheers,

Hannes
-- 
Dr. Hannes Reinecke                Kernel Storage Architect
hare@suse.de                              +49 911 74053 688
SUSE Software Solutions GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), Geschäftsführer: Felix Imendörffer
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help