Re: [PATCH v2 1/3] PM suspend/hibernate: Call notifier after freezing processes
From: Rafael J. Wysocki <hidden>
Date: 2015-07-20 21:19:49
Also in:
dm-devel, linux-pm, lkml
From: Rafael J. Wysocki <hidden>
Date: 2015-07-20 21:19:49
Also in:
dm-devel, linux-pm, lkml
On Monday, July 20, 2015 09:32:26 AM Pali Rohár wrote:
On Saturday 18 July 2015 01:27:15 Rafael J. Wysocki wrote:quoted
On Thursday, July 16, 2015 09:33:02 AM Pali Rohár wrote:quoted
On Thursday 16 July 2015 03:02:03 Rafael J. Wysocki wrote:quoted
Also, if you're adding AFTER_FREEZE, it would be good to add BEFORE_THAW too for symmetry.But there is no use case for BEFORE_THAW. At least it is not needed for now.For your use case, a single function pointer would be sufficient too.What do you mean by single function pointer? kernel/power is part of kernel image and dm-crypt is external kernel module.
Well, if there is a function pointer in the core suspend code initially set to NULL and exported to modules such that the dm-crypt code can set it to something else, that should be sufficient, shouldn't it? So if you're adding new PM notifier events, that's already more than *you* need. Anyway, I guess the "post freeze" new one should be enough for now, but please change the name to POST_FREEZE. Also I think we don't need separate "post freeze" events for suspend and hibernation. Thanks, Rafael