Thread (25 messages) 25 messages, 4 authors, 2025-07-24

Re: [PATCH v4 1/6] dt-bindings: phy: samsung,usb3-drd-phy: add ExynosAutov920 HS phy compatible

From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2025-07-23 08:42:49
Also in: linux-arm-kernel, linux-devicetree, linux-samsung-soc, lkml

On 23/07/2025 07:11, Pritam Manohar Sutar wrote:
quoted
On 22/07/2025 06:34, Pritam Manohar Sutar wrote:
quoted
quoted
quoted
quoted
Nothing is explained in changelog/cover letter. You claim you only
added Rb
tag.
quoted
quoted
This is an entirely silent change while keeping the review.
Will add more explanations in cover letter/changelog why this block is
added.
quoted
quoted
quoted
quoted
Combined with not even following DTS style!
Ok got it. Will change supplies name as below avdd075_usb =>
avdd075-usb
avdd18_usb20 => avdd18-usb20
avdd33_usb20 => avdd33-usb20

Confirm the above change that is meant in terms of DTS style.
Yes. I have doubts that actual supplies have suffix usb20. Are there
more than one avdd18 for this block?
Yes, there are more than one vdd18 supplies for this block.
And their names are?
quoted
Re-analysed your comment on adding new supplies.
Going to re-use existing supplies as mentioned below, rather than
introducing new supplies

  dvdd-usb20-supply   => for 0.75v
  vddh-usb20-supply   => for 1.8v
  vdd33-usb20-supply => for 3.3v

You just expect us to guess whether this is correct...
Sorry about not being clear so far. 

V920 needs three supplies, 0.75v, 1.8v and 3.3v for USB PHY
The naming convention used in the schematic are
avdd075-usb, 
avdd18_usb20, 
avdd33_usb20.

However, PHY's user manual just mentions DVDD, VDD33 and VDD18.

Then dvdd, vdd33 and vdd18.
Since GS101 binding already using supply names similar to what is mentioned in the PHY user manual.

GS101 has USB 2.0 and DP, thus the suffix made some sense. I think you
have only USB 2.0, that's why I question the suffix.


Best regards,
Krzysztof

-- 
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help