Re: [GIT PULL] Memory folios for v5.15
From: Matthew Wilcox <willy@infradead.org>
Date: 2021-08-26 17:20:29
Also in:
linux-fsdevel, lkml
On Tue, Aug 24, 2021 at 12:48:13PM -0700, Linus Torvalds wrote:
On Tue, Aug 24, 2021 at 12:38 PM Linus Torvalds [off-list ref] wrote:quoted
"pageset" is such a great name that we already use it, so I guess that doesn't work.Actually, maybe I can backtrack on that a bit. Maybe 'pageset' would work as a name. It's not used as a type right now, but the usage where we do have those comments around 'struct per_cpu_pages' are actually not that different from the folio kind of thing. It has a list of "pages" that have a fixed order. So that existing 'pageset' user might actually fit in conceptually. The 'pageset' is only really used in comments and as part of a field name, and the use does seem to be kind of consistent with the Willy's use of a "aligned allocation-group of pages".
The 'pageset' in use in mm/page_alloc.c really seems to be more of a pagelist than a pageset. The one concern I have about renaming it is that we actually print the word 'pagesets' in /proc/zoneinfo. There's also some infiniband driver that uses the word "pageset" which really seems to mean "DMA range". So if I rename the existing mm pageset to pagelist, and then modify all these patches to call a folio a pageset, you'd take this patchset?