Thread (161 messages) 161 messages, 27 authors, 2021-10-25

Re: [GIT PULL] Memory folios for v5.15

From: Linus Torvalds <torvalds@linux-foundation.org>
Date: 2021-08-24 19:48:37
Also in: linux-fsdevel, lkml

On Tue, Aug 24, 2021 at 12:38 PM Linus Torvalds
[off-list ref] wrote:
"pageset" is such a great name that we already use it, so I guess that
doesn't work.
Actually, maybe I can backtrack on that a bit.

Maybe 'pageset' would work as a name. It's not used as a type right
now, but the usage where we do have those comments around 'struct
per_cpu_pages' are actually not that different from the folio kind of
thing. It has a list of "pages" that have a fixed order.

So that existing 'pageset' user might actually fit in conceptually.
The 'pageset' is only really used in comments and as part of a field
name, and the use does seem to be kind of consistent with the Willy's
use of a "aligned allocation-group of pages".

                 Linus
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help