Re: [GIT PULL] Memory folios for v5.15
From: Linus Torvalds <torvalds@linux-foundation.org>
Date: 2021-08-24 18:30:15
Also in:
linux-fsdevel, lkml
From: Linus Torvalds <torvalds@linux-foundation.org>
Date: 2021-08-24 18:30:15
Also in:
linux-fsdevel, lkml
On Tue, Aug 24, 2021 at 11:26 AM Linus Torvalds [off-list ref] wrote:
If anything, I'd make things more explicit. Stupid and straightforward. Maybe just "struct head_page" or something like that. Name it by what it *is*, not by analogies.
Btw, just to clarify: I don't love "struct head_page" either. It looks
clunky. But at least something like that would be a _straightforward_
clunky name.
Something like just "struct pages" would be less clunky, would still
get the message across, but gets a bit too visually similar.
Naming is hard.
Linus