On Tue, Aug 24, 2021 at 11:26:30AM -0700, Linus Torvalds wrote:
On Tue, Aug 24, 2021 at 11:17 AM Matthew Wilcox [off-list ref] wrote:
quoted
If the only thing standing between this patch and the merge is
s/folio/ream/g,
I really don't think that helps. All the book-binding analogies are
only confusing.
If anything, I'd make things more explicit. Stupid and
straightforward. Maybe just "struct head_page" or something like that.
Name it by what it *is*, not by analogies.
I don't mind calling it something entirely different. I mean, the word
"slab" has nothing to do with memory or pages or anything. I just want
something short and greppable. Choosing short words at random from
/usr/share/dict/words:
belt gala claw ogre peck raft
bowl moat cask deck rink toga