On Sun, Oct 1, 2023 at 5:13 PM Duje Mihanović [off-list ref] wrote:
If this code is left in the board file, the sync GPIO would have to be
separated into another lookup table during conversion to the GPIO
descriptor API (which is also done in this patch).
The only user of this code (Sharp Spitz) is also converted in this
patch.
Suggested-by: Linus... ?
...
+static void ads7846_wait_for_sync(struct ads7846 *ts)
I would name it ..._wait_for_sync_gpio.
...
+ ts->sync = devm_gpiod_get_optional(dev, "sync", GPIOD_IN);
+ if (IS_ERR(ts->sync)) {
+ dev_err(dev, "Failed to get sync GPIO: %pe\n", ts->sync);
+ return PTR_ERR(ts->sync);
return dev_err_probe(...); ?
+ }
--
With Best Regards,
Andy Shevchenko