On Mon, 15 Feb 2021 15:00:30 -0800
Roderick Colenbrander [off-list ref] wrote:
What is the desired naming for these player LEDs? There is not an
officially designed function based on DT bindings. So far they used
"playstation::mac::ledX". When changing the naming scheme towards
"hid" and removing MAC, they would be: "hid%d::led1" etcetera.
Hi,
there is one more thing I forgot to mention in the LED name schema:
devicename:color:function-functionEnumerator
So LED core can for example compose a names in the format:
switch0:green:lan-1
switch0:green:lan-2
switch0:green:lan-3
switch0:green:lan-4
In your case I think the most appropriate name would be something like
hid0:color:indicator-1
hid0:color:indicator-2
...
Are these LEDs of different colors which are impossible to determine?
The string "hid%d::led1" you mention above does not indicate color.
Marek