This small series enhances the readability of the code by refactoring the
ad7280_channel_init and ad7280_attr_init functions.
The readability is enhanced by splitting the functions into more functions that
do more specific operations.
Since v1:
* The patch "staging: iio: adc: ad7280a: add braces to complex for loops" has
been removed. It's not needed anymore.
Slawomir Stepien (2):
staging: iio: adc: ad7280a: split ad7280_channel_init() to more
functions
staging: iio: adc: ad7280a: split ad7280_attr_init() to more functions
drivers/staging/iio/adc/ad7280a.c | 243 +++++++++++++++++++-----------
1 file changed, 158 insertions(+), 85 deletions(-)
--
2.19.2