On Mon, Feb 20, 2012 at 12:51 PM, Tejun Heo [off-list ref] wrote:
Overall the patchset looks good but
On Mon, Feb 20, 2012 at 12:09:21PM -0800, Brian Norris wrote:
quoted
+ AHCI_HFLAG_STRICT_SPEC = (1 << 15), /* strict AHCI spec */
can you please use something more specific? e.g. something like
SKIP_ENGINE_ON_PORT_START and then explain what the flag is about in
the comment?
So you want AHCI_HFLAG_SKIP_ENGINE_ON_PORT_START? That seems
excessively long... how about AHCI_HFLAG_DELAY_ENGINE? (since it
pushes the start engine call back to the error-handling stage)
I agree the STRICT_SPEC name is a little too generic, but I couldn't
immediately come up with something better.
Brian