Re: Re: [PATCH] Sysfs for framebuffer
From: Sven Luther <hidden>
Date: 2004-03-23 12:26:33
Also in:
lkml
On Tue, Mar 23, 2004 at 12:11:00PM +0100, Jan De Luyck wrote:
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 On Monday 22 March 2004 20:57, Greg KH wrote:quoted
On Mon, Mar 22, 2004 at 09:50:46AM +1100, Benjamin Herrenschmidt wrote:quoted
quoted
I prefere graphics myself. Display sounds to generic. That is what video and graphics output is piped to. Since fbdev doesn't handle video ouput normally this is kind of fuzzy sounding.I still prefer display...Bah, I don't want to argue here. I've applied Kronos's patch as is to my device-2.6 tree which will end up in the next -mm release. I'll hold off forwarding this patch to Linus until after 2.6.5 is out, so that gives everyone a few days in which to argue the name a bunch and then send me a patch that changes it to the decided apon name (if it is to be changed.)- From a users point of view: if there are only to be framebuffer devices listed in this class, why not call it just what it is: "Framebuffer" ? Naming it after something it is only in a broad sense makes no sense to me. I'd be looking in /sys/.../framebuffer instead of /sys/.../graphics or /display.
Notice that /display is what is used by most OF implementations, so this kinda makes sense. I would vote like BenH on this if i was consulted.
Display would be the EDID info of my screen (physical), and graphics... well... I'd half expect something like capture cards to be there...
But this also makes sense, still, i guess we are concerned with more info than just the framebuffer, right ? Friendly, Sven Luther ------------------------------------------------------- This SF.Net email is sponsored by: IBM Linux Tutorials Free Linux tutorial presented by Daniel Robbins, President and CEO of GenToo technologies. Learn everything from fundamentals to system administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click