Thread (17 messages) flat view 17 messages, 6 authors, 2011-12-09

Re: [PATCH 4/5 resend] VFS: Rename vfs_check_frozen() to vfs_block_until_thawed()

From: Jan Kara <jack@suse.cz>
Date: 2011-12-07 22:46:12
Also in: linux-fsdevel, lkml

On Tue 06-12-11 06:40:25, Christoph Hellwig wrote:
On Mon, Dec 05, 2011 at 12:54:48PM -0800, Kamal Mostafa wrote:
quoted
From: Valerie Aurora <redacted>

The name of vfs_check_frozen() tends to de-emphasize an important
fact: that it will block until the file system thaws to the specified
level.  Make bugs slightly less likely by renaming to
vfs_block_until_thawed().
I really hate that name.  The old one wasn't perfect either, but unless
you have a really good new one I'm strongly in favour of not repainting
the bikeshed.
  Maybe vfs_wait_frozen()?

								Honza
-- 
Jan Kara [off-list ref]
SUSE Labs, CR
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help