Thread (17 messages) flat view 17 messages, 6 authors, 2011-12-09

Re: [PATCH 4/5 resend] VFS: Rename vfs_check_frozen() to vfs_block_until_thawed()

From: Christoph Hellwig <hch@infradead.org>
Date: 2011-12-06 11:40:25
Also in: linux-fsdevel, lkml

On Mon, Dec 05, 2011 at 12:54:48PM -0800, Kamal Mostafa wrote:
From: Valerie Aurora <redacted>

The name of vfs_check_frozen() tends to de-emphasize an important
fact: that it will block until the file system thaws to the specified
level.  Make bugs slightly less likely by renaming to
vfs_block_until_thawed().
I really hate that name.  The old one wasn't perfect either, but unless
you have a really good new one I'm strongly in favour of not repainting
the bikeshed.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help