Thread (25 messages) 25 messages, 8 authors, 2026-01-07

Re: [PATCH v2 1/4] dt-bindings: i2c: qcom-cci: Document sm6150 compatible

From: Loic Poulain <loic.poulain@oss.qualcomm.com>
Date: 2026-01-07 10:35:50
Also in: linux-arm-msm, linux-i2c, linux-media, lkml

On Wed, Jan 7, 2026 at 11:08 AM Wenmeng Liu
[off-list ref] wrote:


On 1/7/2026 4:34 PM, Krzysztof Kozlowski wrote:
quoted
On 07/01/2026 09:17, Wenmeng Liu wrote:
quoted

On 1/7/2026 4:00 PM, Krzysztof Kozlowski wrote:
quoted
On Tue, Jan 06, 2026 at 05:39:53PM +0800, Wenmeng Liu wrote:
quoted
+  - if:
+      properties:
+        compatible:
+          contains:
+            enum:
+              - qcom,sm6150-cci
+    then:
+      properties:
+        clocks:
+          minItems: 3
+          maxItems: 3
+        clock-names:
+          items:
+            - const: soc_ahb
Same question as before. I did not see any resolution of this in
changelog or commit msg.
Will update commit msg in next version:

For this platform, it uses soc_ahb instead of camnoc_axi.
That was not my question from v1. AHB and AXI are both bus clocks,
meaning for this device the same. You again name the clocks how you
called them in clock controller which is wrong. You name here CLOCK
INPUTS. What is the role of this clock FOR THIS DEVICE?

I already asked to pay attention to this difference.

Best regards,
Krzysztof
Ok, i got it, just feel a bit confused.

+                       clocks = <&camcc CAM_CC_SOC_AHB_CLK>,
+                                <&camcc CAM_CC_CPAS_AHB_CLK>,
+                                <&camcc CAM_CC_CCI_CLK>;
+                       clock-names = "camnoc_axi",
+                                     "cpas_ahb",
+                                     "cci";


        clocks = <&camcc CAM_CC_SOC_AHB_CLK>,
        clock-names = "camnoc_axi";

If this is acceptable, I will update it this way in the next version.
No, the idea is to name the clock from the device’s perspective.
For example, from the CCI perspective, you typically have:
- A core clock, clocking the logic, which could be named 'core' (but
'cci' here is ok)
- Clocks related to the bus interfaces (such as AHB or AXI), which
could be named 'iface...' or 'bus...'.

This approach clearly identifies the role of each clock and keeps
naming consistent, without depending on where the clock originates or
its source name.

From that standpoint, some of the existing bus clock names defined in
qcom,i2c-cci.yaml are not ideal. You can find better naming in bindings
like qcom,i2c-qup.yaml or qcom,i2c-geni-qcom.yaml.

Regards,
Loic
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help