Thread (41 messages) 41 messages, 8 authors, 2022-07-19

Re: [PATCH 0/4] add support for bias pull-disable

From: Linus Walleij <hidden>
Date: 2022-07-18 10:26:06
Also in: linux-acpi, linux-gpio

On Fri, Jul 15, 2022 at 9:31 PM Bartosz Golaszewski [off-list ref] wrote:
On Fri, Jul 15, 2022 at 2:19 PM Nuno Sá [off-list ref] wrote:
Ideologically I don't have anything against adding this flag (except
Ugh that sounds political :)
that it should be called BIAS_DISABLE not PULL_DISABLE IMO). Nuno is
right in that the character device is the only way to set this mode
ATM and. However I would like to see the first user added together
with the series because adding features nobody uses in the mainline
kernel tree is generally frowned upon and it's also not clear that
anyone actually wants to use it.
I agree: makers and tinkerers definitely need this flag and it will further
emplasize the transition to the character device and to the v2 character
device interface (which, by the way, is looking awesome, especially when
taken into the picture the libgpiod changes and the new language
bindings for libgpiod).

So we need to add this to become ever more appealing for one-offs
such as industrial control.

Yours,
Linus Walleij
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help