Thread (18 messages) 18 messages, 4 authors, 2021-08-16

Re: [PATCH v5 1/5] iio: adc: ad7949: define and use bitfield names

flat view

From: Joe Perches <joe@perches.com>
Date: 2021-08-08 16:51:56
Also in: linux-iio, lkml

On Sat, 2021-08-07 at 21:56 -0400, Liam Beguin wrote:
Replace raw configuration register values by using FIELD_PREP and
defines to improve readability.
[]
quoted hunk ↗ jump to hunk
diff --git a/drivers/iio/adc/ad7949.c b/drivers/iio/adc/ad7949.c
[]
+#define AD7949_CFG_BIT_INCC		GENMASK(12, 10)

I think the naming is a bit confusing as it appears as if
these bitfield ranges are single bits.
+/* REF: reference/buffer selection */
+#define AD7949_CFG_BIT_REF		GENMASK(5, 3)
[]
+/* SEQ: channel sequencer. Allows for scanning channels */
+#define AD7949_CFG_BIT_SEQ		GENMASK(2, 1)
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help