On Wed, Sep 16, 2015 at 02:54:53PM -0500, Andreas Dannenberg wrote:
On Wed, Sep 16, 2015 at 05:10:06PM +0900, Krzysztof Kozlowski wrote:
quoted
On 16.09.2015 02:58, Andreas Dannenberg wrote:
quoted
static DEVICE_ATTR(ovp_voltage, S_IRUGO, bq24257_show_ovp_voltage, NULL);
static DEVICE_ATTR(in_dpm_voltage, S_IRUGO, bq24257_show_in_dpm_voltage, NULL);
This applies to previous patches actually: DEVICE_ATTR_RO?
Ok. Will simplify.
Actually I looked into this more and realized that the use of the
pre-configured DEVICE_ATTR_* definitions imposes certain function names,
which would mean renaming the functions including dropping the bq24257_
prefix those function names have, making the code inconsistent and
decreasing the unique-ness of those function names in the global Kernel
namespace. So I rather leave the more general DEVICE_ATTR() definitions
in place.
Regards,
--
Andreas Dannenberg
Texas Instruments Inc