Re: [PATCH 3/4] pinctrl: remove slew-rate parameter from tz1090
From: Linus Walleij <hidden>
Date: 2013-06-25 15:39:23
Also in:
lkml
On Tue, Jun 25, 2013 at 3:50 PM, James Hogan [off-list ref] wrote:
On 25/06/13 14:32, Linus Walleij wrote:
quoted
Patches adding it back in with SI measures will be welcomed!Okay. So the most descriptive documentation I can find for the slew rate in the TZ1090 pin config hardware is basically: 0: slow (half frequency) 1: fast Sounds like this pretty much precludes it from having a generic DT binding unless it can be mapped to some physical value, so I'll add a tz1090,slew-rate and use PIN_CONFIG_END+1 instead of PIN_CONFIG_SLEW_RATE.
Okay... ut the Nomadik pin controller incidentally have a similar definition: NMK_GPIO_LOWEMI. By slashing the slew rate in half the EMI is of course reduced so that was another name for the same thing. Maybe this is something that should just be boolean? slewrate-reduced-slope; ?
Anybody object to me adding an argument to pinconf_generic_parse_dt_config() so that an additional pinconf_generic_dt_params array can be optionally passed in? That way I can share the generic pinconf dt parsing code.
Hm hm hm, that sounds more like it could be a separate utility function. Then it could help to parse any such array of custom bindings. Yours, Linus Walleij