This patchset is replace open coded divisor calculations with the
DIV_ROUND_UP kernel macro for better readability.
Wu Bo (2):
crypto: af_alg - use DIV_ROUND_UP helper macro for calculations
fs: direct-io: use DIV_ROUND_UP helper macro for calculations
crypto/af_alg.c | 2 +-
fs/direct-io.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
--
1.8.3.1
@@ -411,7 +411,7 @@ int af_alg_make_sg(struct af_alg_sgl *sgl, struct iov_iter *iter, int len)if(n<0)returnn;-npages=(off+n+PAGE_SIZE-1)>>PAGE_SHIFT;+npages=DIV_ROUND_UP(off+n,PAGE_SIZE);if(WARN_ON(npages==0))return-EINVAL;/* Add one extra for linking */
@@ -411,7 +411,7 @@ int af_alg_make_sg(struct af_alg_sgl *sgl, struct
iov_iter *iter, int len)
if (n < 0)
return n;
- npages = (off + n + PAGE_SIZE - 1) >> PAGE_SHIFT;
+ npages = DIV_ROUND_UP(off + n, PAGE_SIZE);
You should use PFN_UP()
No. We are not using pfns here - we're converting a byte count to a
page count.
Besides, "PFN_UP" is a horrible, awful api. It does not decribe what
it does and anyone who is not a mm developer will look at it and ask
"what <the ....> does this do?" and have to go looking for it's
definition to determine what it does. Yes, that's exactyl what I've
just done, and I really wish I didn't because, well, it just
reinforces how much we suck at APIs...
OTOH, what DIV_ROUND_UP() does is obvious, widely understood, self
documenting and easy to determine if the usage is correct, which
indeed this is.
The lesson: do not use whacky obscure, out of context macros when a
simple, obvious, widely known macro will give the same result and
make the code easier to understand.
Cheers,
Dave.
--
Dave Chinner
david@fromorbit.com