On Tue, Dec 14, 2021 at 11:46:14AM -0600, Venu Busireddy wrote:
What I am suggesting should not have anything to do with the boot stage
of the kernel.
I know exactly what you're suggesting.
For example, both these functions call native_cpuid(), which is declared
as an inline function. I am merely suggesting to do something similar
to avoid the code duplication.
Try it yourself. If you can come up with something halfway readable and
it builds, I'm willing to take a look.
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette