Thread (6 messages) flat view 6 messages, 2 authors, 2012-11-15
STALE5010d

[PATCH BlueZ 2/5] core: Make exit sequence consistent with init

From: Luiz Augusto von Dentz <luiz.dentz@gmail.com>
Date: 2012-11-15 14:05:22
Subsystem: the rest · Maintainer: Linus Torvalds

From: Luiz Augusto von Dentz <redacted>

manager_cleanup should be called after plugin_cleanup on exit as
manager_init is called before plugin_init on the init sequence.
---
 src/main.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/main.c b/src/main.c
index 9ea12df..414849a 100644
--- a/src/main.c
+++ b/src/main.c
@@ -545,12 +545,12 @@ int main(int argc, char *argv[])
 
 	g_source_remove(signal);
 
+	plugin_cleanup();
+
 	manager_cleanup("/");
 
 	rfkill_exit();
 
-	plugin_cleanup();
-
 	stop_sdp_server();
 
 	g_main_loop_unref(event_loop);
-- 
1.7.11.7
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help